Billing dashboard and user management pages partially unaccessible
Incident Report for Catalyst Cloud
Resolved
This incident has been resolved.
Posted Aug 07, 2024 - 12:45 NZST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 07, 2024 - 11:46 NZST
Investigating
We are currently investigating this issue.
Posted Aug 07, 2024 - 11:21 NZST
This incident affected: Dashboard.